【デジタル】ドメイン全体にかけていたGAタグがおかしかった件

1月25日をもって、終了したみたいな感じ。というか、そもそも1月24日にしても一人しか来てないって「ええ??」って感じでした。というのも、少なくとも実験用に自分自身複数のツールで見に行っていたから。

ここ数日、いろいろ検証してもドメイン全体にかけているGoogle Analyticsがまったく反応値を示さないという事件が起きていました。画面的には、左にある感じ。まぁ、ご臨終な感じでWordpress側は息を吹き返して数字が徐々に来ているのに、親ドメインの数字がまったく上がらないという怪奇現象だったのです。流石に、これには参って「何が起きてるの?」って調べても全然わからず。まず一番簡単なチェックとしては、Chromeに積んでるGhosteryで、そもそもGTMが稼働しているかをチェック。しかし、問題なく動いていることを確認。念のため、ドメイントップとWPトップとWP記事で比較するも変化はなし。本当は、ここで「お?」ってのがあればよかったんだけどGhosteryではGoogle Tag Manager経由でGAタグを設置しても表層のGTMタグを認識したとしてもその奥にあるGAのタグIDまでは掘り起こせないんですよ。なので、この状態では稼働日稼働を判断できない。判断できるのは、GTMが動いていることだけ。

ここ見ても、GTMのタグが稼働していることしかわからず、その内側はわかりません。

次に見たのが、Chromeのディベロッパーツール。この中の”Network”の”Other”を選ぶと”ga-audiences?v=1&….”ってのが見えるのですが、これがGAタグなのです。ここで見ると、タグが一個しか表示されていない。ということで、「GTMは稼働している」「だけど、GAは一つしか稼働していない」ということがわかりました。そこまでくると、調べるのはGTMのみ。「多分設定間違ってたんだろうなー」ということになりました。

画像内、黒枠部分の文字にマウスオンするとタグ情報が見れます。ここで、トラッキングIDが正しいかチェック!

ということで、GTMを開いて丁寧に見直し。ぱっと見、特におかしくないなと思っていたんだけど、初めて見る「オーバーライド設定」というのが有効になっている。これは、今までやったことない設定。ということで、これが原因だろうなーと感じたのでチェックを外し変数を普通に全体用GAタグ直呼び出しに変更。トラッキングタグも間違ってないか念のためチェックしたけど、問題なさそう。通常、GAタグの発火は1日かかるんだけど、すぐ稼働確認したい場合は、GA画面のリアルタイム画面でわかるので稼働チェック。「動きましたー( ´ ▽ ` )」ということで、一件落着。しかし、なんでオーバーライド設定にしていたのか、これがいつこうなったのかは謎。合わせて、その状態でなぜたまに1名だけ反応していたのかについてもわからず終い。まぁ、動いたからいいけどね。

Google Analytics実装で、仕事やプライベートのページ運用をきちんと見ながら改善していくという作業は基本中の基本だと思いますが、このような落とし穴があるのも事実。実際、こういうことが起きてもマニュアル的なものが乏しいため「なんでこうなった?」が本当にわかりづらいというのが現実。ただ、こういう現象が起きたとしてもいくつかのツールを使って冷静に分析すれば自ずと原因がわかります。チェック時は、同じGoogleのプロダクトとなるChromeを使ったチェックが一番いいのではないかと感じています。ただ、僕のデフォルトブラウザーはFireFoxだけどねw。

ではでは、皆様また!

コメントを残す

このサイトはスパムを低減するために Akismet を使っています。コメントデータの処理方法の詳細はこちらをご覧ください